A WordPress észlelte, hogy a webhelyünk egy nem biztonságos PHP verzióval üzemel.” Ha ez az üzenet fogadja a WordPress admin felületén, akkor nem kell azonnal kétségbeesnie. Egyszerűen csak frissítenie kell a PHP verziót a tárhelyének az admin felületén.

Azt gondolnának azzal, hogy folyamatosan frissítjük az oldalunkon használt WordPress verziót, a bővítményeket és sablonokat már mindent meg is tettük az oldalunk biztonsága és hosszú távú működése érdekében. Ez sajnos nem igaz, hiszen fontos a WordPress oldalunk mögötti „háttér rendszer” folyamatos karbantartása és frissítése is.

Ezt alapvetően minden tárhelyszolgáltató automatikusan megteszi. A háttérben folyamatosan fejlesztenek, frissítenek és javítják a szervereket és szoftvereket, amik segítenek az oldalunk megfelelő működésében. Ha ezeket a lépéseket mégsem teszi meg a tárhelyszolgáltatója, tehát nem fejleszt és nem javítja a szolgáltatásainak minőségét, akkor azt a szolgáltató kerülje el!

Ahhoz, hogy megoldhassa ezt a problémát és átállíthassa a PHP verzióját be kell lépnie a tárhelykezelő felületére. Manapság a legnépszerűbb és leggyakrabban használt felület a cPanel. Tehát, mi is a cPanelen belüli szükséges lépéseket fogjuk végig venni.

Ezek a lépések pedig az alábbiak a PHP beállításának:

  1. Lépjen be a cPanel felületére, majd keresse meg a „Select PHP version” hivatkozást a kezelőfelületen. Miután megtalálta és rákattintott, akkor a hivatkozás át fogja vinni a PHP beállítások felületére, aminek a neve a PHP Selector.
  2. A „Current PHP version” melletti legördülő menüre kell kattintani, majd miután lenyílt a menü ott fogja tudni kiválasztani az Önnek megfelelő PHP verziót. Egyszerűen válassza ki a PHP verziót és mentse el a beállításokat.

Amennyiben az előző módszerrel nem sikerül átváltania a PHP verziót, azaz még mindig fent áll a probléma és a korábbi üzenet fogadja a WordPress admin felületén, akkor van egy másik menüpont is, ahol szükséges lehet elvégezni a beállításokat.

Ez a menüpont nem más, mint a „MultiPHP Manager”, ebben a menüpontban be fogja tudni állítani a PHP verziót a megfelelő domainhez.

Nézzük is a második módszer lépéseit:

  1. Lépjen be a cPanel kezelőfelületére, majd keresse meg a „MultiPHP Manager” menüpontot. Ha megtalálta, akkor kattintson rá és megjelenik a beállítási ablak.
  2. Miután megjelent a beállítási felülete a MultiPHP Manager-nek, válasszá ki alul az ablakban, hogy melyik domain-en szeretné a PHP beállítási lehetőségeket elvégezni.
  3. Miután kiválasztotta a domain-t alul, akkor az ablak jobb oldalán a PHP verzió szöveg melletti legördülő menüben válaszhatja ki a beállítandó PHP verziót. Miközben átállítja a PHP verziót érdemes arra figyelnie, hogy az ea-php előtagúakból válassza ki a magának szükséges PHP verziót. Miután kiválasztotta kattintson az Alkalmaz gombra.

Ha sikeresen beállította a PHP verziót a fenti két módszer egyikének segítségével, akkor ellenőrizze le honlapjának a működését. Ha esetleg valamelyik bővítmény nem megfelelően működik, akkor próbálja meg frissíteni azt, vagy utána járni, hogy mi lehet a probléma. Ha nincs hozzá javítás, akkor vagy kapcsolja ki a bővítményt, vagy keressen egy másikat helyette, ami működik és folyamatosan frissítik.

Hasonló cikkek


Olvasson tovább

Biztonság és az iThemes Security plugin

Tartalomjegyzék Mi van ha nincs ilyen feltelepítve? Többek között ezeket is tudja a kiegészítő Hogyan kell beállítani? Adminisztrációs felület elrejtése Adatbázis...


wordpress biztonsag
miert olyan jo a wordpress weboldal
Miért olyan jó a WordPress weboldal?

Tartalomjegyzék Kiknek való a wordpress? Miket tud a WordPress Mennyi idő elkészíteni? Megszámlálhatatlan kész dizájn Mai modern technológia Rendkívül megbízható,...


Ossza meg ezt!